华为S2700交换机

用户视图:
reset saved-configuration 恢复出厂配置
reboot重启
save 保存 sa
quit 退出 q

系统视图:
system-view 系统视图 sy简写
disp curr 显示当前配置
display saved-configuration 显示保存的配置

display version 查看版本
display interface brief 查看接口情况

vlan 200 创建200
undo vlan 200 删除

interface Ethernet0/0/24
port acc vlan 200
interface Ethernet0/0/1 to interface Ethernet0/0/24 1到24
port access vlan 200

port link-type access
port link-type trunk
port default vlan 200

[Quidway] interface gigabitethernet 0/0/2
[Quidway-GigabitEthernet0/0/2] combo-port fiber  //转换为combo口

PS:combo口 是电口和光口只能使用一个,默认是光电复用。

三种模式:

Access模式:

一般用来连接计算机与交换机. 此模式下有一个PVID就是本端口所属的VLAN号,如果从链路上收到无标签的帧,则打上默认VLAN号,然后发给其他端口,如果从链路上收到有标签的帧,如果这个帧的VLAN等于PVID,则直接发给其他端口,如果不等于PVID,则直接丢弃.如果从其他端口收到一个有标签的帧,且VLAN等于PVID,则直接剥离掉标签从此端口发出,如果此标签不等于PVID,则直接丢弃.

Trunk模式:

一般用于各交换机之间连接.此模式下有一个PVID和允许通过的VLAN ID列表. 如果从链路上收到一个不带标签的帧,则直接打上PVID号,转发到其他端口, 如果从链路上收到一个带标签的帧,且此帧的VLAN号在允许通过的VLAN列表里,则直接转发给其他端口; 如果从其他端口收到一个有标签的帧,且此帧的VLAN等于PVID,则直接剥离掉标签,并从此端口发出,如果此标签不等于PVID,则查看此帧的VLAN号是否在允许通过的VLAN列表里,如果在,则直接从此端口发出,否则丢弃.

Hybrid模式:

此模式下,有一个默认的PVID号,一个untagged列表和一个tagged列表. 如果从链路上收到一个无标签的帧,则打上PVID号,转发到其他端口,如果从链路上收到一个带标签的帧,且此帧的VLAN号在untagged或者tagged列表中的其中任意一个列表里,则直接转发到其他端口,否则丢弃. 如果从其他端口收到一个有标签的帧,且帧的VLAN号在tagged列表里,则直接从此端口发出,如果VLAN号在untagged列表里,这剥离掉帧的VLAN标签,然后从此端口发出.

三种视图: 用户视图, 系统视图, 接口视图

用户视图: 刚开始登入交换机时的视图,一般看到的是尖括号<> .

save    // 配置完交换机后保存当前配置的命令
system-view    // 进入系统视图的命令
clock  timezone  BJ  add|minus 8   // 设置时区
clock  datetime  16:36:00 2016-07-01    //设置交换机的时间

系统视图: 在用户视图下输入system-view后进入系统视图,一般为方括号[]

display current-configuration  // 显示当前配置
user-interface maximum-vty 15  //配置vty最大连接数
user-interface vty 0 14     //进入vty用户界面视图
user privilege level 2      //设置vty登入的用户等级为2(配置用户级别)
authentication-mode aaa  //设置vty登入时的验证模式为用户名和密码验证

aaa  //进入AAA视图
local-user admin password cipher admin@123  //设置aaa登入的用户名和密码
local-user admin service-type telnet  //设置admin用户远程登入时的协议

user-interface console 0     //进入第0个console口的用户界面
authentication-mode passwd   //配置从console口登入交换机的认证模式为密码认证
set authentication password cipher admin@123  //配置从console口登入交换机的密码
vlan 10  //创建一个VLAN


interface meth 0/0/1   //进入交换机的第一个管理网口
ip address 192.168.1.110 24 //设置管理网口的ip地址和子网掩码

interface gigabitethernet 0/0/1 //进入第一个业务网口
port link-type access  //设置第1个网口位access模式
port default vlan 10   //设置此网口的VLAN号为10

interface gigabitethnet 0/0/2 //进入第2个业务网口
port link-type trunk   //设置第二个网口位trunk模式
port trunk allow-pass vlan 10 20 30  //设置此端口可以通过的VLAN号
             // port trunk allow-pass vlan all  表示可以通过所有的带VLAN的帧

Interface gigabitethnet 0/0/3  //进入第3个业务网口
Port link-type hybrid     //设置此端口为hybrid模式,每个端口默认就是hybrid模式
Port hybrid pvid vlan 10   //设置pvid为10
Port hybrid tagged vlan 20 30 40 //设置tagged列表为20,30,40
Port hybrid untagged vlan 50 60 //设置untagged列表为50,60

Display port vlan  //显示当前各端口的VLAN情况
清除某个端口的配置
Interface gigabitethernet 0/0/2
Clear configuration this
Undo shutdown

Interface gigabitethernet 0/0/3
Undo port default vlan  //access 模式的端口
Undo port link-type 
Undo port hybrid pvid vlan vlanid  //hybrid 模式的端口
Undo port hybrid untagged vlan vlanid 
Undo port hybrid tagged vlan vlanid 
Undo port trunk pvid vlan  //trunk 模式的端口
Undo port trunk allow-pass vlan vlanid 
Undo port link-type

恢复出厂设置
在用户视图下(按Ctrl+z组合键回到用户视图)输入如下命令操作
reset saved-configuration
Y
Reboot
N
Y
设置交换机的mux-vlan模式
假设主VLAN是10,从VLAN中group模式的有VLAN 20, separate模式的有VLAN 30,server连接1号端口,PC1和PC2连接23号端口,PC3和PC4连接45号端口
Vlan batch 10 20 30
Vlan 10
Mux-vlan
Subordinate group 20
Subordinate separate 30
把各连接的端口设为access模式,并且加入到各自的VLAN中,且同时开启mux-vlan功能,
Interface gigabitethernet 0/0/1        
Port link-type access
Port default vlan 10
Port mux-vlan enable
Interface gigabitethernet 0/0/2       //3号端口设置方法类似
Port link-type access
Port default vlan 20
Port mux-vlan enable
Interface gigabitethernet 0/0/4      //5号端口设置方法类似
Port link-type access
Port default vlan 30
Port mux-vlan enable
三层交换机接路由器LAN口
Vlan 60 70
Interface vlanif 60
ip address 192.168.60.1 24
interface vlanif 70
ip address 192.168.1.238 24
interface gigabitethernet 0/0/3
port link-type access
port default vlan 60
interface gigabitethernet 0/0/4
port link-type access
port default vlan 70
ip route-static 0.0.0.0 0.0.0.0 192.168.1.1
在与交换机相连的路由器上设置一条静态ip地址,目的地址为交换机相关的各个网段地址,网关为交换机与路由器相连的vlanif的ip地址
批量配置交换机端口
vlan batch 10 20
port-group 1
group-member gigabitethernet 0/0/1 to gigabitethernet 0/0/10
port link-type access
port default vlan 10

 

本文固定链接: http://blog.wmphp.com/2447.html | 顺盛网络博客

该日志由 admin 于2018年05月20日发表在 Huawei 分类下, 你可以发表评论,并在保留原文地址及作者的情况下引用到你的网站或博客。
原创文章转载请注明: 华为S2700交换机 | 顺盛网络博客

华为S2700交换机:等您坐沙发呢!

发表评论


快捷键:Ctrl+Enter